F5 BIG-IP icon   F5 BIGIP – LTM Policy GUI incorrectly shows conditions with datagroups



The last F5 BIGIP version 13.1.0.2 (I upgraded from v13.0.0 some days ago – 2018 February) seems to generate a bug with the LTM policies.

Symptoms

Fortunately, the issue is only at the Presentation layer. The LTM policy show the rules conditions always with datagroups. This affects all rules and policies.

Better explained with an example:
If this is a rule correctly displayed…
F5 BIGIP - Example rule of an LTM Policy…in this new version, the GUI and shows the rule like this:
F5 BIGIP - Bug that shows incorrectly the conditions with datagroups

Keep calm because this is not what really is applying internally. It is only incorrectly showed.

Workaround

To avoid having errors due to this bug, one possible solution is using TMSH to modify the rules. See K33749970: Managing local traffic policies on the BIG-IP system using the tmsh utility

Anyway, modifying the rules using the GUI is still possible. But take into account that the draft policy conditions will be incorrectly created so fixing them is also needed before save and publishing. Otherwise, the rules could start to fail (like it happened to me).

When changing again to “any of”, the values are again populated so it is easy to reconfigure them again even when lots of host names, paths or whatever… were configured.

F5 BIGIP - Changing the condition from datagroup to "any of"F5 BIGIP - Changing the condition to "any of" populates automatically the values

Bug

Opened a technical case in F5 support. The BUG iD for this issue is 688911.
I will keep you updated about it

2 thoughts on “F5 BIGIP – LTM Policy GUI incorrectly shows conditions with datagroups

Leave a Reply

Your email address will not be published. Required fields are marked *